Comandos Cisco Switch

Aquí tenéis una guía resumen de comandos de Cisco para Switching.

MODO EXEC USUARIO

Comando Descripción
ping {dirección_ip|nombre} Envía una petición de eco para diagnosticar la conectividad básica de red
show cdp interfaces [tipo número] Muestra información acerca de las interfaces en las que CDP está habilitado
show history Muestra el historial de comandos ingresados
show ip interface brief Muestra un breve resumen de la información y del estado de una dirección IP
show ip route [dirección |protocolo] Muestra el contenido de la tabla de enrutamiento IP.
show version Muestra información sobre el Cisco IOS y la plataforma
traceroute dirección_ip Muestra la ruta tomada por los paquetes hacia un destino

MODO EXEC PRIVILEGIADO

Comando Descripción
configure terminal Configura la terminal manualmente desde la terminal de consola
copy flash:vlan.dat tftp Copia la configuración VLAN del sistema desde la memoria Flash a un servidor TFTP
copy running-config startup-config Guarda la configuración activa en la NVRAM
copy startup-config tftp Almacena la configuración activa en un servidor TFTP
copy tftp flash:vlan.dat Descarga una copia de la configuración VLAN desde un servidor TFTP en la memoria Flash
copy tftp startup-config Carga la información de configuración desde un servidor TFTP
disable Sale del modo EXEC Privilegiado hacia el modo EXEC Usuario
erase flash Borra el contenido de la memoria Flash
delete flash:vlan.dat Borra el archivo VLAN.DAT de la memoria Flash
write erase Borra el contenido de la NVRAM
reload Reinicia el router
show access-lists [Nro_ACL|Nombre_ACL] Muestra el contenido de todas las ACL en el router. Para ver una lista específica, agregue el nombre o número de ACL como opción.
show arp Muestra la asignación de direcciones IP a MAC a Interfaz del router
show flash Muestra la disposición y contenido de la memoria Flash
show interfaces [tipo número] Muestra estadísticas para la/las interfaces indicadas
show ip interface [tipo número] Muestra los parámetros de estado y globales asociados con una interfaz
show ip protocols [summary] Muestra los parámetros y estado actual del proceso de protocolo de enrutamiento activo
show protocols Muestra los protocolos de capa 3 configurados
show running-config Muestra la configuración actual en la RAM
show startup-config Muestra la configuración que se ha guardado, que es el contenido de la NVRAM
show vtp status Permite verificar la configuración del dominio VTP.

MODO DE CONFIGURACIÓN GLOBAL

Comando Descripción
access-list Nro_ACL {permit|deny} Origen Crea o agrega una sentencia de condición a la ACL que permitirá o denegará los paquetes que llegan desde un Origen.

Origen puede ser una dirección IP más una máscara wildcard, la palabra host más una dirección IP o el wildcard any

access-list Nro_ACL {permit|deny} Proto Origen Destino [Operador Nro_puerto] [established] [echo |echo-reply] Crea o agrega una sentencia de condición a la ACL que permitirá o denegará los paquetes que lleguen desde un Origen y vayan hacia un Destino.

  • Proto identifica el protocolo a verificar.
  • Origen y Destino pueden ser una dirección IP más una máscara wildcard, la palabra host más una dirección IP o el wildcard any.
  • Operador puede ser lt (menor que), gt (mayor que), eq (igual a) o neq (distinto a).
  • Nro_puerto indica el puerto TCP o UDP.
  • El parámetro established permite el paso de tráfico cuando hay una sesión establecida. En el caso del protocolo ICMP se puede utilizar echo o echo-reply.
Banner motd #mensaje del día# Configura un cartel con un mensaje del día.
enable password contraseña Establece una contraseña local para controlar el acceso a los diversos niveles de privilegio.
enable secret contraseña Especifica una capa de seguridad adicional mediante el comando enable password.
hostname nombre Modifica el nombre del router
interface tipo número Configura un tipo de interfaz y entra al modo de configuración de interfaz
ip access-list {s­tandard|extended} Nombre Permite crear una ACL nombrada

Se debe indicar el tipo. Este comando ingresa al router al submodo de configuración que puede reconocerse por el prompt Router(config-ext-nacl)#

ip classless Permite que el router no tome en cuenta los límites con definición de clases de las redes en su tabla de enrutamiento y simplemente transmita hacia la ruta por defecto
ip default-network dirección_ red Establece una ruta por defecto
Ip route dirección_red máscara dir_ip_salto [distancia_administrativa] Establece rutas estáticas
line tipo número Identifica una línea específica para la configuración e inicia el modo de introducción de comandos de configuración. Ej: line console 0 ó line vty 0 4
router protocolo_de_enrutamiento [nro_AS] Inicia un proceso de enrutamiento definiendo en primer lugar un protocolo de enrutamiento IP Ej: router rip ó router igrp 120
service password-encryption Habilita la función de cifrado de la contraseña
vtp [mode] {server | client | transparent} Selección del modo VTP del switch.
vtp pruning Permite la poda en el dominio VTP.
vtp domain nombre-dominio Nombre del dominio VTP

SUBMODO DE CONFIGURACIÓN DE INTERFAZ

Comando Descripción
cdp enable Habilita Cisco Discovery Protocol en una interfaz
description descripción Agrega una descripción a la interfaz
ip access-group Nro_ACL [in|out] Asigna la ACL indicada a la interfaz, ya sea para que verifique los paquetes entrantes (in) o los salientes (out)
ip address dirección_ip mascara_red Asigna una dirección y una máscara de subred e inicia el procesamiento IP en una interfaz.
no shutdown Reinicia una interfaz desactivada
shutdown Inhabilita una interfaz
spanning-tree portfast Hace que por un puerto de acceso no se transmitan tramas bridge de spanning-tree
spanning-tree bpduguard enable Protege un puerto de acceso configurado como portfast de forma que si el puerto detecta alguna trama bridge, que se pueda transmitir por error, se bloquea inmediatamente.
no switchport Hace que un puerto de switch se convierta en interfaz y admita configuración IP
switchport mode trunk Convierte un puerto de switch en troncal
switchport trunk encapsulation dot1q Indica que por ese puerto troncal circularán tramas etiquetadas con el estándar dot1q
switchport trunk native vlan 2 Configura la VLAN como predeterminada
switchport trunk {allowed | pruning} vlan [add|all|except|remove] vlan-list Configura las VLANs permitidas (allowed) o filtradas (pruning).
switchport mode access Convierte un puerto de switch en puerto de acceso
switchport access vlan Nro_VLAN Indica que por un puerto solo pueden pasar tramas de la VLAN indicada

SUBMODO DE CONFIGURACIÓN DE LÍNEA

Comando Descripción
login Habilita la verificación de contraseña en el momento de la conexión
password contraseña Asigna la contraseña a ser solicitada en el momento de la conexión

Deja un comentario

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies ACEPTAR

Aviso de cookies